The Lab
WordPress: Featured Posts Timeline
June 20, 2019
bug_report_tiny.png 16:17  Bug report FP-33 - Posts Do Not Show Feature Image Thumbnail on Homepage
Guest user (guest) : Issue created
Trying to add a post with a featured image (as we've done for years) and show it, with 480 x 285 pixel thumbnail on the homepage. Said image does not load.

Here is a section of code that shows a new post (that doesn't load an image) vs. an older post:


<li class="col-sm-6 post">
<div class="block-top">
</div>
<div class="block-content">
<h3 class="block-heading">
<a href="https://imeaconnect.com/2019/06/19/distribution-in-a-model-driven-age/">Distribution in a Model-Driven Age</a>
</h3>
<div class="block-exerpt">
<p>New Broadridge survey reveals why financial advisors use model portfolios and the implications for asset managers.</p>
</div>
<div class="block-meta">
<span class="entry-date updated">
<a href="https://imeaconnect.com/2019/06/19/distribution-in-a-model-driven-age/">
<time datetime="2019-06-19 11:22:27">06/19/2019</time>
</a>
</span> | <span class="entry-comments">
<a href="https://imeaconnect.com/2019/06/19/distribution-in-a-model-driven-age/#respond">
<i class="fa fa-comments-o"></i>
0
</a>
</span> </div>
</div>
</li>
<li class="col-sm-6 post">
<div class="block-top">
<a href="https://thestarawards.com/categories/#1553536347418-55451f40-4277"><img src="https://imeaconnect.com/wp-content/uploads/2018/04/STARAwards_2018-480x285.png" alt="STAR Awards: New 2019 Category" width="480" height="285"><div class="overlay"><i class="fa fa-plus"></i></div></a> </div>
<div class="block-content">
<h3 class="block-heading">
<a href="https://thestarawards.com/categories/#1553536347418-55451f40-4277">STAR Awards: New 2019 Category</a>
</h3>
<div class="block-exerpt">
<p>A new Product Education Campaign category has been added in both the Investor and Advisor areas.</p>
</div>
<div class="block-meta">
<span class="entry-date updated">
<a href="https://thestarawards.com/categories/#1553536347418-55451f40-4277">
<time datetime="2019-06-11 11:40:59">06/11/2019</time>
</a>
</span> | <span class="entry-comments">
<a href="https://thestarawards.com/categories/#1553536347418-55451f40-4277#respond">
<i class="fa fa-comments-o"></i>
0
</a>
</span> </div>
</div>
</li>
October 12, 2016
bug_report_tiny.png 20:08  Bug report FP-32 - Remove comment block
Guest user (guest) : Issue created
When I insert the default shortcode into my index page I get the "featured posts" bloc but also, I'm stuck with the "post comment" bloc right below. How can I remove the "comment bloc"? There are no settings for that?
August 29, 2016
bug_report_tiny.png 13:51  Bug report FP-31 - Thumbnail image not correct
Guest user (guest) : Issue created
I'm using the shortcode on a static page. The image being pulled from the post is a modified version of the actual featured image - a smaller version. For example, in a given post the featured image is this:

https://i1.wp.com/www.maiztostado.com/wp-content/uploads/2016/08/cannes.jpg

But the html shows that the image is this:

https://i1.wp.com/www.maiztostado.com/wp-content/uploads/2016/08/cannes.jpg?fit=445%2C250

Here's the html for reference:

<img scale="0" src="http://i1.wp.com/www.maiztostado.com/wp-content/uploads/2016/08/cannes.jpg?fit=445%2C250" alt="Cannes 2016" height="250" align="left" width="700">

Somehow it is adding "?fit=445%2C250" to the filename and changing the image to a different size.

I need it to use the original image, the one set as "featured image" in the post.
June 17, 2016
enhancement_tiny.png 07:38  Enhancement FP-30 - Thumbnail
be well (be_well) : Issue created
I am trying to display thumbnails if my featured posts and everything is working fine. The thing is that the image for thumbnail is not generating (not cropping) by the params I've set up on plugin's settings page. Sure, the style of my choice is added to <img> tag, but this is not working when you have some narrow images uploaded. Can you, please, fix this.
[[Image:http://dl1.joxi.net/drive/2016/06/17/0012/3895/831287/87/2eb3517c04.png|Screenshot]]
enhancement_tiny.png 07:35  Enhancement FP-29 - Thumbnail
be well (be_well) : Issue created
I am trying to display thumbnails if my featured posts and everything is working fine. The thing is that the image for thumbnail is not generating (not cropping) by the params I've set up on plugin's settings page. Sure, the style of my choice is added to <img> tag, but this is not working when you have some narrow images uploaded. Can you, please, fix this.
[[Image:http://dl1.joxi.net/drive/2016/06/17/0012/3895/831287/87/2eb3517c04.png|Screenshot]]
enhancement_tiny.png 07:33  Enhancement FP-28 - Thumbnail
be well (be_well) : Issue created
I am trying to display thumbnails if my featured posts and everything is working fine. The thing is that the image for thumbnail is not generating (not cropping) by the params I've set up on plugin's settings page. Sure, the style of my choice is added to <img> tag, but this is not working when you have some narrow images uploaded. Can you, please, fix this.
[[Image:http://dl1.joxi.net/drive/2016/06/17/0012/3895/831287/87/2eb3517c04.png|Screenshot]]
enhancement_tiny.png 07:32  Enhancement FP-27 - Thumbnail
be well (be_well) : Issue created
I am trying to display thumbnails if my featured posts and everything is working fine. The thing is that the image for thumbnail is not generating (not cropping) by the params I've set up on plugin's settings page. Sure, the style of my choice is added to <img> tag, but this is not working when you have some narrow images uploaded. Can you, please, fix this.
[[Image:http://dl1.joxi.net/drive/2016/06/17/0012/3895/831287/87/2eb3517c04.png|Screenshot]]
February 07, 2016
icon_build.png 07:00 WordPress: Featured Posts version 1.3.0
New version released
enhancement_tiny.png 02:01  Enhancement FP-26 - Upgrade Settings UI
Sharron Denice (sharrondenice) : Issue closed
enhancement_tiny.png 01:17  Enhancement FP-26 - Upgrade Settings UI
Sharron Denice (sharrondenice) : Issue created
Upgrade Settings UI
February 04, 2016
enhancement_tiny.png 18:20  Enhancement FP-25 - Eliminate the use of Easy Dev Pro
Sharron Denice (sharrondenice) : Issue closed
enhancement_tiny.png 17:53  Enhancement FP-25 - Eliminate the use of Easy Dev Pro
Sharron Denice (sharrondenice) : Issue created
Easy Dev Pro is currently being discontinued and only Easy Dev will be used for easier development.
icon_build.png 07:00 WordPress: Featured Posts version 1.2.9
New version released
November 06, 2015
bug_report_tiny.png 15:47  Bug report FP-24 - Fix various bugs throughout plugin
Sharron Denice (sharrondenice) : Issue closed
bug_report_tiny.png 15:36  Bug report FP-24 - Fix various bugs throughout plugin
Sharron Denice (sharrondenice) : Issue created
Fix various bugs throughout plugin
icon_build.png 07:00 WordPress: Featured Posts version 1.2.8
New version released
April 29, 2015
feature_request_tiny.png 10:45  Feature request FP-23 - Edit text display
tyrnaki (tyrnaki) : Issue created
Hello,

I have combed through the php and I am unable to find the "published on" text that goes into the widget. In other words, I would like to remove "published on" and simply only show the published date.

Please let me know how I can resolve this issue.
January 09, 2015
feature_request_tiny.png 02:53  Feature request FP-21 - Allow for additional post types
Sharron Denice (sharrondenice) : Issue closed
bug_report_tiny.png 02:51  Bug report FP-22 - Plug in settings not editable
Sharron Denice (sharrondenice) : Issue closed
January 08, 2015
bug_report_tiny.png 21:53  Bug report FP-22 - Plug in settings not editable
tom (semide) : Issue created
Plug in loads with default settings. Works in front end as expected. Attempting to change settings in admin causes a blank page with the message "Cannot load tsp-featured-posts.php." Settings will not change.
icon_build.png 20:52 WordPress: Featured Posts version 1.2.7
New version released
January 01, 2015
icon_build.png 23:44 WordPress: Featured Posts version 1.2.6
New version released
feature_request_tiny.png 23:40  Feature request FP-21 - Allow for additional post types
Sharron Denice (sharrondenice) : Issue created
Currently the WFP can only display posts, add features to support multiple post types.
icon_build.png 06:00 WordPress: Featured Posts version 1.2.4
New version released
December 20, 2014
feature_request_tiny.png 09:11  Feature request FP-20 - Add New Features to Posts
Sharron Denice (sharrondenice) : Issue closed
feature_request_tiny.png 07:55  Feature request FP-20 - Add New Features to Posts
Sharron Denice (sharrondenice) : Issue created
Currently when posts are displayed, all HTML formatting is stripped out. Update code to allow for keeping HTML formatting and also add in code to add in CSS style formatting for posts.
icon_build.png 03:10 WordPress: Featured Posts version 1.2.3
New version released
icon_build.png 02:00 WordPress: Featured Posts version 1.2.2
New version released
September 11, 2014
bug_report_tiny.png 09:58  Bug report FP-17 - Cannot get the summary to not appear
Sharron Denice (sharrondenice) : Issue closed
bug_report_tiny.png 09:56  Bug report FP-18 - Featured image not being rendered correctly (ignoring height completely)
Sharron Denice (sharrondenice) : Issue closed
September 07, 2014
enhancement_tiny.png 18:12  Enhancement FP-19 - Make multiple enhancements for plugin - Blackley Enhancement
Sharron Denice (sharrondenice) : Issue closed
icon_build.png 01:06 WordPress: Featured Posts version 1.2.1
New version released
September 02, 2014
enhancement_tiny.png 22:10  Enhancement FP-19 - Make multiple enhancements for plugin - Blackley Enhancement
Sharron Denice (sharrondenice) : Issue created
- Have the thumbnail linked to the article
- To allow for the [...] to be hyperlinked to the article and to be able to change the text of the [...] to user defined text
- The ability to remove the CR after the author/date entry so that you could say something like [Author], [Date] | [Excerpt]
- Turn thumbnails on/off
August 19, 2014
bug_report_tiny.png 07:21  Bug report FP-15 - Bug report - Slider not working
Sharron Denice (sharrondenice) : Issue closed
August 18, 2014
bug_report_tiny.png 13:15  Bug report FP-18 - Featured image not being rendered correctly (ignoring height completely)
theamazingdoug@gmail.com : Issue created
I am attempting to use this for a couple of posts on the front page. While I can get it to function perfectly in every single section- there is one, in which it won't work.

Under Book an Event and Open Mic- the image is completely ignoring the height and looks to be using a weird cropped image instead of the image I am intending.

For instance: it is pulling in this code. <source lang="php"><img height="140" width="295" align="left" alt="Open Mic Night" src="http://www.mothafalcon.com/stanfords/wp-content/uploads/2014/08/2PSoLa4u41i2UNJIHo-f_dS_55LkgvFqrxqsVC9yQz0-150x150.jpg"></source>

But if I change it to... <source lang="php"><img height="140" width="295" align="left" alt="Open Mic Night" src="http://www.mothafalcon.com/stanfords/wp-content/uploads/2014/08/2PSoLa4u41i2UNJIHo-f_dS_55LkgvFqrxqsVC9yQz0.jpg"></source>

It magically works.

Why is it making its own version of the image when none of the others do?
August 05, 2014
bug_report_tiny.png 11:45  Bug report FP-17 - Cannot get the summary to not appear
theamazingdoug@gmail.com : Issue created
I have tried removing the entry summary from the new template I created- but it completely louses up my ability to show the post title- placing the positioning all wonky.

With the [...] displaying (I have no content there yet) it pushes my title to the bottom. If I remove it- it shoots the title to the top.

Is there no way to remove that?

<source lang="php">[tsp-featured-posts title="This Week" max_words=0 show_quotes=N" show_text_posts="N" number_posts="1" category="4" layout="5" order_by="DATE" thumb_width="600" thumb_height="266" before_title="
<h3 class="widget-title">" after_title="</h3>
"]
</source>

April 16, 2014
bug_report_tiny.png 10:46  Bug report FP-16 - Slider does not show
pelchatcr@gmail.com : Issue created
The slider option just leaves a blank space on the page with nothing showing.
bug_report_tiny.png 10:41  Bug report FP-15 - Bug report - Slider not working
pelchatcr@gmail.com : Issue created
Hello

The slider feature is not working. It just leaves a large black area when that option is selected.
bug_report_tiny.png 10:40  Bug report FP-14 - Bug report - Slider not working
pelchatcr@gmail.com : Issue created
Hello

The slider feature is not working. It just leaves a large black area when that option is selected.
February 26, 2014
feature_request_tiny.png 00:23  Feature request FP-13 - Allow List of Post IDs to contain spaces between commas
Sharron Denice (sharrondenice) : Issue closed